Technical Team/Minutes/2011-03-29

From SPDX Wiki
Jump to: navigation, search

Minutes 3/29/2011 and 3/30/2011

Attendees 3/29/2011

  • Nicholas Loke
  • Branden Robinson
  • Kristin Newcomer
  • Bill Schineller
  • Kate Stewart
  • Gary O'Neall
  • Peter Williams

Attendees 3/30/2011

  • Jack Manbeck
  • Bill Schineller
  • Gary O'Neall
  • Nicholas Loke
  • Marshal
  • Peter Williams
  • Kate Stewart


  • Review naming spreadsheet updates
  • Discuss ways to represent the RDF entities in the spec


  • Reviewed Creator change name to creationInfo (property) and CreationInfo (Class)
  • Discussion on if we should prepend property names with cardinality of 1 to N with “has” – we will decide after completing the rest of the spreadsheet
  • Format of the spreadsheet RDF column: propertyName/Range (and/or class)
  • Proposal for Beta – remove the CreationInfo class, add back a property for creator – range Agent, add a creatorComment property - string
  • Future – proposal to add changelog class and property to Analysis
  • Todo: Gary to re-align spreadsheet rows

We decided to have a follow-on call on Wednesday, 2:00PM Eastern. Bill will send out an invite.

Continuation of the call

  • Agreed to go back to a simple model for creator (property spdx:creator) and comment – (property spdx:creatorComment). We discussed whether comment should be spdxcreatorComment or rdfs:comment. Concluded that the semantics are different enough to create an SPDX specific property.
  • Discussed the use of the Checksum class and alternatives to providing the extensibility (e.g. separate properties for each algorithm and having the algorithm be identified through the subclass of Checksum rather than a property). Decided on using the checksum class as it allows for additional / different properties based on the algorithm and keeping the algorithm property.
  • Change property name from spdx:packageChecksum to spdx:checksum since it is semantically the same property as the file property – Note: we did not (and probably should) update the fileChecksum to checksum.
  • Discussed whether we should change the range of the packageVerificationCode to a Checksum class. We decided to leave it as a literal string for now, although most people on the call thought that we should make this field more extensible. We will revisit this during and/or after beta.
  • Licensing discussion:
    • We discussed the name and meaning of the “NonStandardLicense”. Agreed to rename the field (see spreadsheet for resolved name)
    • We discussed whether the RDF model should have the previously named “NonStandardLicense” as a subclass of License. We will pick up this discussion in our face to face meeting.
    • The LicenseSets (ConjunctiveLicenseSet and DisjunctiveLicenseSet) will both contain LicensingInfo objects.

Note: there will not be a call next Tuesday, we will meet again at the face to face meeting at the Linux Collaboration Summit